compilation - 我需要交叉编译内核模块来为 beaglebone black编译内核模块?

  显示原文与译文双语对照的内容
0 0

我想用我自己的桌面电脑( BeagleBone ),以英镑为代价,在十英镑的交叉编译中,用我的台式电脑,并运行。 BeagleBone Black也运行 debain,但是这两台机器有不同的内核。

我只想在桌面PC上安装ARM的内核头,但是我不知道哪个deb需要安装。 我已经安装了arm-linux-gnueabi-*的版本。

BeagleBone Black上的内核是:


Linux beaglebone 3.8.13-bone47 #1 SMP Fri Apr 11 01:36:09 UTC 2014 armv7l GNU/Linux

我需要deb做什么内核头?

这些是我已经安装的:


linux-headers-3.2.0-4-all 
linux-headers-3.2.0-4-all-amd64 
linux-headers-3.2.0-4-amd64 
linux-headers-3.2.0-4-common 
linux-headers-3.2.0-4-common-rt 
linux-headers-3.2.0-4-rt-amd64 

时间: 原作者:

0 0

显然这是不可能的- Debian在Debian中似乎没有任何Linux头软件包比 3.2晚了。*

原作者:
...