java - 我的java版本是 1.7. but Maven 使用 jdk 1.6

  显示原文与译文双语对照的内容
0 0

这个问题已经有了如下答案:

我的java版本是 1.7. but Maven 使用 jdk 1.6

java -version java版本"1.7.0_55""

mvn --version提供了 Apache Maven 3.0.4 Maven 主页: /usr/share/maven Java版本:1.6.0 _31,供应商: Sun Microsystems公司的主页: /usr/lib/jvm/java-6-openjdk-amd64/jre 默认语言环境:en_IN,平台编码: UTF-8 操作系统名称:"linux",版本: "3 。8.0-37-generic"。arch:"",:"unix"

在尝试 mvn clean安装时,我正在获取生成 failer 。to要做什么。

我的system.java 1.7和 java 1.6. but 安装了两个版本的java,当安装 Maven 时,可以使用 java 1.6. how 安装 Maven 。

java --version给出

java版本"1.7.0_55"

时间: 原作者:

0 0

你的路径上的Java可能与JAVA_HOME环境属性不同。 请看这个答案。

0 0

Maven 使用JAVA_HOME参数来查找应该运行哪个Java版本。


You can set the JAVA_HOME parameter just before you start maven (and change it back afterwards if need be).
You could also go into your mvn(non-windows)/mvn.bat(windows) and set your java version explicitly there.

...