nginx - 同时,如何安装 PHP-FPM 5.5 rpm安装所有依赖项

  显示原文与译文双语对照的内容
0 0

我在网上运行 centos6. 当我写命令的时候


# rpm -ivh ftp://195.220.108.108/linux/remi/enterprise/6/test/i386/php-fpm-5.5.4-1.el6.remi.i686.rpmrpm -ivh ftp://195.220.108.108/linux/remi/enterprise/6/test/i386/php-fpm-5.5.4-1.el6.remi.i686.rpm

输出为


# rpm -ivh ftp://195.220.108.108/linux/remi/enterprise/6/test/i386/php-fpm-5.5.4-1.el6.remi.i686.rpm
Retrieving ftp://195.220.108.108/linux/remi/enterprise/6/test/i386/php-fpm-5.5.4-1.el6.remi.i686.rpm
error: Failed dependencies:
 php-common(x86-32) = 5.5.4-1.el6.remi is needed by php-fpm-5.5.4-1.el6.remi.i686

所以我去php通用安装


# rpm -Uvh ftp://195.220.108.108/linux/remi/enterprise/6/test/i386/php-common-5.5.4-1.el6.remi.i686.rpm

它有这些依赖关系


Retrieving ftp://195.220.108.108/linux/remi/enterprise/6/test/i386/php-common-5.5.4-1.el6.remi.i686.rpm
error: Failed dependencies:
 php-pecl-jsonc(x86-32) is needed by php-common-5.5.4-1.el6.remi.i686
 php-pecl-zip(x86-32) is needed by php-common-5.5.4-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-cli-5.4.20-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-pdo-5.4.20-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-gd-5.4.20-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-5.4.20-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-fpm-5.4.20-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-xml-5.4.20-1.el6.remi.i686
 php-common(x86-32) = 5.4.20-1.el6.remi is needed by (installed) php-mbstring-5.4.20-1.el6.remi.i686

我的question-有任何方法可以立即安装它们? 抱歉,如果我是 noob !

时间: 原作者:

0 0

使用 yum

基于我在目录中看到的文件,我猜它是"remi"构建的镜像。 我在 http://rpms.famillecollet.com/ 找到的。 对于 CentOS 6,只需安装的repo RPM 然后再。

原作者:
...