apache - 在 Ubuntu apache/2.4 ( Ubuntu ) 安装 RApache: 我有些错误

  显示原文与译文双语对照的内容
116 2

我尝试在 RApache 16.04 apache/2.4 中安装,但我得到了一些错误:

1-首先安装软件包:

sudo apt安装 apache2-prefork-dev apache2-mpm-prefork libapreq2-dev r-base-dev

我收到一条错误消息:

软件包apache2-mpm-prefork不可用,但由另一个软件包引用。 这可以能意味着包丢失,已经被废弃,或者仅从另一个源可以用

E: 无法找到软件包 apache2-prefork-dev E: 软件包'apache2-mpm-prefork'没有安装候选项

当我尝试时

debuild -us -uc

我收到消息:

这个软件包有一个Debian版本,但是在父目录中似乎没有一个合适的原始tar文件或者. orig 目录;( 。要求一个 libapache2-mod-r-base_1.2.8.orig 。orig 。orig 。libapache2-mod-r-base_1.orig 。orig 。orig 。lzma 。libapache2-mod-r-base_1.2.8.orig.tar.xz 。或者 rapache.orig 。) 仍然继续。 ( y/n )

我决定是,但它不工作,我得到:

dpkg-buildpackage -rfakeroot -D -us -uc dpkg: 警告:使用gain-root-command作为 root dpkg-buildpackage时: 源软件包 libapache2-mod-r-base dpkg-buildpackage: 源版本 1.2.8 -xenial0 dpkg-buildpackage: 源分发 xenial0 dpkg-buildpackage: 由 Jeroen Ooms dpkg源 --before-build rapache dpkg-buildpackage更改: checkbuilddeps: 错误的主机体系结构: 未满足的构建依赖项:apache2-dev dpkg-buildpackage: 警告:构建依赖项/冲突不满意;中止 dpkg-buildpackage: 警告:( 使用-d标志替代。) debuild: 第 1376行出现致命错误: dpkg-buildpackage -rfakeroot -D -us -uc失败

有谁能帮助我?

我非常感激你能提供任何帮助。

Roberto

时间: 原作者:

120 4

你丢失了一堆文件。 参见官方文档准备适当的目录结构,适合打包。 请参见这里软件包源代码的示例。

...