php - php如何将 NetBeans 8.0与Codeigniter集成

  显示原文与译文双语对照的内容
129 0

我是使用 Netbeans IDE开发php的新手。我使用 NetBeans 8.0版本。我想使用Codeigniter框架开发一个项目。但是我仍然无法找到使用Codeigniter模板启动项目的方法。

当我创建一个新项目时,sdl要求我使用数量的php框架,比如 as 。Nette2.Zend2.Doctrine & 等等 。

我尝试了stackoverflow中的许多解决方案。但是有些是针对老的netbeans版本的,其他的不适合我。

我从 https://github.com/nbphpcouncil/nb-ci-plugin/releases 下载了 netbeans CI插件。

当我尝试安装插件时,NetBeans说它需要安装更多插件。

如何将Codeigniter框架集成到 NetBeans 8.0.?

请提前致谢。

时间:原作者:0个回答

62 4

我正在使用 NetBeans 8.2补丁 2 ( 完全内部) 。我从链接中安装了NBM文件,你粘贴,一切都很好。如果你不希望完全 IDE,那么你需要NetBeans和PHP支持。因此在安装 2 nbm文件之后,我可以在新的PHP项目向导中选择codeigniter框架。

此致

克里斯

原作者:
...