node.js - node.js: 安装移动第一个开发套件和迁移协助的正确 node js 版本是什么

  显示原文与译文双语对照的内容
107 1

我有移动服务器的第一个版本: 8.0.0.00 -20180220 -083852

但是,从那里我下载了cli和迁移辅助工具,我总是得到这个错误:

npm错误node v6.9.3 npm错误 ! 代码 npm ERR 代码npm错误 ! syscall ENOTFOUND npm ERR 系统调用 getaddrinfo !

网络 getaddrinfo ENOTFOUND visustar.francelab.fr.ibm.com visustar.francelab.fr.ibm.com:8081 npm错误 ! 网络这很可能不是npm本身的npm错误 ! 网络与网络连接相关。 在大多数情况下,你的网络位于代理后面,或者网络设置不正确。 网络npm错误 ! 如果你在代理后面,请确保npm错误 ! 网络'代理'配置设置正确。 请参阅:'帮助配置''

npm ERR 请在任何支持请求中包含以下文件: ! npm错误G:mobilenodejsnpm-debug. 日志 !

我对stackoverflow进行了搜索,但是所有建议都是使用正确的nodejs和npm版本。 我相信我已经用了正确的。

有什么想法顺便说一下,我正在使用 Windows 10?

时间: 原作者:

110 4

支持的最小 node.js 版本为 4.2.3 。 而且,随着 node 和npm包的快速发展,MobileFirst CLI可能无法完全使用 node 和npm的所有可用版本,包括最新版本。 确保 node 处于 6.11.1版本,并且npm版本为 3.10.10,以便正确运行。

有关详细信息,请参见这里: 先决条件

...