android - Cordova构建:请安装Android目标:" 22.我不希望安卓 22. 我想要安卓 19,我该做什么?

  显示原文与译文双语对照的内容
56 4

我正在努力与phonegap设置和构建我的第一个应用。

我创建了一个hello1项目。 我添加了android项目

android平台已经添加

现在当我运行cordova构建时,我得到了错误-

错误:请安装Android目标: android-22""

我没有 android-22. 我有 android-19.我希望我的项目是用android-19构建的。 我怎么才能做到?

我有 android-22,我卸载了( 为了解决更大的问题) 。 我不明白我应该对这个文件做什么更改才能工作。 项目中的project.properties 在这个步骤之后,它自动将目标包含为 android-22.

我已经正确地添加了环境变量。 C:Usersuserandroid-sdksplatform-tools;C:Usersuserandroid-sdkstools

它没有帮助。这只是我试图调试的更大问题的一部分。 请帮助。

时间: 原作者:

138 5

SDK SDK ( "android-21" )


$ cordova platforms remove android


$ cordova platforms add android@3.7.1



SDK ( Android 4.1.1,"android-22" )


$ cordova platforms remove android


$ cordova platforms add android@4.1.1



更多信息:https://cordova.apache.org/announcements//cordova-android-4.1. 0.html

原作者:
...