git - 在部署阶段到 Google App Engine,rick推出部署失败

  显示原文与译文双语对照的内容
0 0

这是来自于这里的来自的问题。

所以我设法让 python 测试运行。 我已经使用push部署指南来配置 Jenkins

我正在执行一个 shell 命令,如下所示:


gcloud --project=cfc-melbourne-website preview app deploy app.yaml

我得到以下错误


[workspace] $/bin/sh -xe/opt/bitnami/apache-tomcat/temp/hudson678919665445088696.sh
+ gcloud --project=cfc-melbourne-website preview app deploy app.yaml
WARNING: The [application] field is specified in file [/opt/bitnami/apps/jenkins/jenkins_home/jobs/CFC Melbourne production pipeline/workspace/app.yaml]. This field is not used by gcloud and should be removed.
WARNING: The [version] field is specified in file [/opt/bitnami/apps/jenkins/jenkins_home/jobs/CFC Melbourne production pipeline/workspace/app.yaml]. This field is not used by gcloud and should be removed.
ERROR: The version [1] declared in [/opt/bitnami/apps/jenkins/jenkins_home/jobs/CFC Melbourne production pipeline/workspace/app.yaml] does not match the current gcloud version [20150509t012658].
ERROR: (gcloud.preview.app.deploy) Errors occurred while parsing the App Engine app configuration.
Build step 'Execute shell' marked build as failure
Finished: FAILURE

请帮助,谢谢。

app.yaml的内容在这里可以看到

时间: 原作者:

0 0

所以我想出来了。 只要添加这个版本,它就可以 !


gcloud --project=cfc-melbourne-website preview app deploy app.yaml --version=1

原作者:
...