gradle - 错误:无法找到:comandroid支持:支持v4: 20.0.+

  显示原文与译文双语对照的内容
0 0

我在 Android Studio 中导入了一个项目,它是在其中构建的。 我需要项目中的v4和v7库。 我的build.gradle 看起来像这样

build.gradle


apply plugin: 'android-library'

android {
 compileSdkVersion 19
 buildToolsVersion '20'
 defaultConfig {
 applicationId 'com.example.sdk'
 minSdkVersion 9
 targetSdkVersion 19
 versionCode 1
 versionName '1.0'
 }
 buildTypes {
 release {
 runProguard false
 proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
 }
 }
 productFlavors {
 }
}

dependencies {
 compile fileTree(dir: 'libs', include: ['*.jar'])
 compile 'com.android.support:appcompat-v7:20.0.+'
 compile 'com.android.support:support-v4:20.0.+'
}

当我与gradle同步时,它总是给出错误消息

找不到:support-v4.android 。支持:: 20.0.+ &找不到: appcompat-v7.android 。支持:: 20.0.+

enter image description here

enter image description here

请事先支持 & 。

时间: 原作者:

0 0

Android 支持知识库丢失,所以转到 Android SDK,安装 Android Support RepositoryAndroid Support Library 。 也可以使用以下方法


compile 'com.android.support:support-v4:20.0.0'
compile 'com.android.support:appcompat-v7:20.0.0'

代替


compile 'com.android.support:appcompat-v7:20.0.+'
compile 'com.android.support:support-v4:20.0.+'

原作者:
0 0

注意:如果你正在使用 Android Studio 开发,请选择并安装Android支持知识库项目。

请参见这里的

原作者:
0 0

Android Studio 转到:工具>> Android>> SDK管理器

选择并安装"extras|android支持知识库""

...