php - IE 特定消息

  显示原文与译文双语对照的内容
0 0

我的站点上的用户SVG图表。 除了 IE 浏览器之外,所有的浏览器都没有问题。 我想为 IE 用户添加一个带有消息的PHP代码 Fragment 。

我想我可以用PHP获取代理信息,但是我不确定如何检测版本。 我相信 IE 9现在支持它,所以我只需要在 9下面的版本。

时间: 原作者:

0 0

你不需要PHP进行这里操作。

相反,使用条件注释( ) 。

原作者:
0 0

你可以使用PHP函数 get_browser 。 请参见这里的

网站包含了许多如何检测浏览器并显示适当消息的示例。

原作者:
0 0

把这个放在 html


<![if lt IE 9]> 
 Show stuff to browsers => IE 9
<![endif]-->
<!--[if lt IE 9]> 
 hide stuff from browsers <IE 9
<![endif]-->

原作者:
...