php - 在Plesk服务器上,两个Wordpress博客能否共享相同的Wordpress核心目录?

  显示原文与译文双语对照的内容
0 0

我正在使用符号链接来共享Wordpress核心目录。 它在我的本地计算机上工作,但是当我尝试将它部署到Plesk服务器时,我有一些问题。 我确实有以下错误:

[Thu Jul 09 10:08:53 2015] [error] [client 74.125.45.136] PHP Warning: require() [<a href='function.require'>function.require</a>]: SAFE MODE Restriction in effect. The script whose uid is 10001 is not allowed to access/var/www/vhosts/mysite2.com/blog/wordpress/wp-blog-header.php owned by uid 10004 in/var/www/vhosts/mysite2/blog/index.php on line 17, referer: http://www.mysite2.com/blog/

我没有 mysite1.com/blog的错误,因为有wordpress文件夹的用户是 mysite1ftp,如下所示:

drwxrwsr-x 69 mysite1ftp group 4096 Jul 9 09:12 mysite1.com
drwxrwsr-x 44 mysite2ftp group 4096 Jul 8 16:53 mysite2.com
drwxrwsr-x 5 mysite1ftp group 4096 Jul 2 11:15 wordpress

你认为有什么解决方法? mysite1ftp和mysite2ftp都可以访问wordpress文件夹?

时间:原作者:2个回答

0 0

你所遇到的问题是Rackspace已经启用了安全模式。 这是一个古老且相当低效的保护PHP安装的方法。 在"最佳"服务器的配置中,可以使用解决方案( ),或者至少是mod-ruid2 。 不停用安全模式,PHP解释器不会在同一请求中评估不同用户拥有的脚本。

原作者:
0 0

假设所有安装都在同一个实例中,因这里可以以在它们之间共享相同的文件。

检查

http://wordpress.stackexchange.com/questions/57109/how-to-share-wordpress-core-library
原作者:
...