python-2.7 - 为 python 安装Tweepy时出错( Mac )

  显示原文与译文双语对照的内容
0 0

我正在使用 python 2.6.6,并且试图下载 tweepy,但是每当我在 python 空闲 shell 中导入tweepy时都会出错。

我已经下载了 tweepy


sudo pip install tweepy

它直接进入/Library/Python/2. 7/站点包,没有问题。

然后我从那个路径进入 tweepy


python setup.py install

但是这个错误消息出现了


/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python: can't open file 'python': [Errno 2] No such file or directory

我已经经过了路径,所有的一切都正确的python 在最后。

但是,当我打开 python 空闲 shell 和

 
import tweepy 

 

出现了"没有名为tweepy的模块"错误。

我很感激你的帮助 !

时间: 原作者:

0 0

就像你从 site-packages 路径中看到的,pip 正在使用 python 2.7,而你显然正在尝试安装以与 2.6一起使用。 除了使用 2.6的问题之外,问题很容易修复- 安装 pip 为 python 2.6.

下载 get-pip.py,然后运行( 假设你的python 命令指向 2.6版本):


sudo python get-pip.py

一旦安装好了,你就可以运行


sudo pip2.6 install tweepy

一切都应该正常工作。

原作者:
...