ruby-on-rails - /. rvm/gems/ruby 2.0.0 p481/gems/ruby 调试 ide 0.4.22/lib/ruby 调试 ide rb: 8: 在 `require': 无法加载此类文件—降低( LoadError )

  显示原文与译文双语对照的内容
0 0
/.rvm/gems/ruby-2.0.0-p481/gems/ruby-debug-ide-0.4.22/lib/ruby-debug-ide.rb:8:in `require': cannot load such file -- debase (LoadError)

我在尝试运行 macosx Mavericks 上的Rails 服务器时出现这个错误。 我使用 Aptana Studio 3进行调试,而设置导致这里问题

gem 文件包含 ruby-debu-ide gem:

source 'https://rubygems.org'
ruby '2.0.0'
# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '4.0.5'
gem 'bootstrap-sass', '2.3.2.0'
gem 'sprockets', '2.11.0'
gem 'bcrypt-ruby', '3.1.2'
gem 'ruby-debug-ide'
时间:原作者:6个回答

0 0

你需要确保debase可用并且可以找到。

查看"gem 列表"的输出,以及它是否包含了。

然后确保它确实位于相应的目录中- 当你使用. rvm 目录时,它必须在你的ruby 版本中,比如 为我,它是在 PREFIX/lib/ruby/site_ruby/2.1.0/的目录。

原作者:
...