web-services - 在 ServiceMix 4.4.2中,没有部署camel示例

  显示原文与译文双语对照的内容
0 0

我正在尝试运行camel-example-cxf网站下载的示例项目。 ( 下载的apache-camel-2.10.2 )

我使用 pom.xml &构建了这个项目,构建成功了。 但是当我尝试在 servicemix ( apache-servicemix-4.4.2 ) 中部署它时,我得到了以下。


karaf@root> ERROR: Bundle org.apache.camel.camel-example-cxf [43] Error starting file:/C:/apache-servicemix-4.4.2/deploy
/camel-example-cxf-2.10.2.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-example-cxf [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.apache.activemq.broker)(version>=5.7.0)(!(version>=6.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-example-cxf [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.apache.activemq.broker)(version>=5.7.0)(!(version>=6.0.0)))
 at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3446)
 at org.apache.felix.framework.Felix.startBundle(Felix.java:1734)
 at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1163)
 at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
 at java.lang.Thread.run(Thread.java:619)

请帮助

时间: 原作者:

0 0

Apache 4.4.2不支持 Camel 2.10. 你需要使用它所附带的驼峰版本,这是驼山 2.8.

Apache ServiceMix 4.5.0将附带 Camel 2.10和 ActiveMQ 5.7. 这里版本目前正在进行中。

原作者:
0 0

我有同样的问题( 但是使用 activemq jar ),发现在运行 Maven 构建时,我使用的版本不一样。 你可以使用"导出"命令( servicemix 命令行 上的类型导出) 找到servicemix使用的jar 文件的版本,你将会知道版本。 如果这与 Maven 构建所使用的不同,那么就会得到错误。 你有两个选项,然后 1. 在 servicemix ( 与 Maven 生成使用的版本相同) 2中安装不同的包。 更改 pom.xml 以生成 Maven 构建。

原作者:
...